Mod_security 2.5 Install Error

Feb 29, 2008

Trying to install mod_security 2.5 on Red Hat box with Apache 2.0.52 per ModSecurity.org installation instructions.

Getting no errors when running:
./configure --with-apxs=/usr/sbin/apxs
or
make

But, when I run 'make test' I get the following:

# make test
/bin/sh /usr/lib/apr/build/libtool --silent --mode=compile gcc -O2 -g -pipe -m32 -march=i386 -mtune=pentium4 -pthread -O2 -g -Wall -Werror -I/usr/include/pcre -I/usr/include/libxml2 -I/usr/include/apr-0 -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE -pthread -I/usr/include/apr-0 -o msc_test.lo -c msc_test.c
In file included from re.h:36,
from modsecurity.h:46,
from msc_test.c:13:
apache2.h:14:23: http_core.h: No such file or directory
apache2.h:15:26: http_request.h: No such file or directory
apache2.h:16:19: httpd.h: No such file or directory
apache2.h:17:24: ap_release.h: No such file or directory
In file included from re.h:36,
from modsecurity.h:46,
from msc_test.c:13:
apache2.h:60: error: syntax error before '*' token
apache2.h:63: error: syntax error before '*' token
apache2.h:72: error: syntax error before "ap_filter_t"
apache2.h:80: error: syntax error before '*' token
apache2.h:82: error: syntax error before '*' token
apache2.h:89: error: syntax error before '*' token
In file included from msc_test.c:13:
modsecurity.h:48:23: ap_config.h: No such file or directory
modsecurity.h:53:25: http_config.h: No such file or directory
modsecurity.h:54:22: http_log.h: No such file or directory
modsecurity.h:55:27: http_protocol.h: No such file or directory
modsecurity.h:123:19: unixd.h: No such file or directory
In file included from msc_test.c:13:
modsecurity.h:145: error: syntax error before "AP_MODULE_DECLARE_DATA"
modsecurity.h:145: warning: type defaults to `int' in declaration of `security2_module'
modsecurity.h:145: warning: data definition has no type or storage class
modsecurity.h:147: error: syntax error before "module_directives"
modsecurity.h:147: warning: type defaults to `int' in declaration of `module_directives'
modsecurity.h:147: warning: data definition has no type or storage class
modsecurity.h:209: error: syntax error before "request_rec"
modsecurity.h:209: warning: no semicolon at end of struct or union
modsecurity.h:210: warning: type defaults to `int' in declaration of `r'
modsecurity.h:210: warning: data definition has no type or storage class
modsecurity.h:223: error: syntax error before '*' token
modsecurity.h:223: warning: type defaults to `int' in declaration of `if_brigade'
modsecurity.h:223: warning: data definition has no type or storage class
modsecurity.h:229: error: syntax error before '*' token
modsecurity.h:229: warning: type defaults to `int' in declaration of `of_brigade'
modsecurity.h:229: warning: data definition has no type or storage class
modsecurity.h:376: error: syntax error before '}' token
modsecurity.h:496: error: syntax error before "apr_global_mutex_t"
modsecurity.h:496: warning: no semicolon at end of struct or union
modsecurity.h:499: error: syntax error before '}' token
In file included from msc_test.c:15:
pdf_protect.h:18: error: syntax error before '*' token
msc_test.c:39: error: syntax error before "ap_filter_t"
msc_test.c: In function `msr_log':
msc_test.c:56: error: dereferencing pointer to incomplete type
msc_test.c:59: error: dereferencing pointer to incomplete type
msc_test.c:60: error: dereferencing pointer to incomplete type
msc_test.c:60: error: dereferencing pointer to incomplete type
msc_test.c:61: error: dereferencing pointer to incomplete type
msc_test.c:62: error: dereferencing pointer to incomplete type
msc_test.c:67: error: dereferencing pointer to incomplete type
msc_test.c:72: error: dereferencing pointer to incomplete type
msc_test.c: At top level:
msc_test.c:77: error: syntax error before '*' token
msc_test.c:81: error: syntax error before '*' token
msc_test.c:85: error: syntax error before '*' token
msc_test.c:89: error: syntax error before '*' token
msc_test.c: In function `test_tfn':
msc_test.c:156: error: dereferencing pointer to incomplete type
msc_test.c: In function `test_op':
msc_test.c:190: error: dereferencing pointer to incomplete type
msc_test.c:201: error: dereferencing pointer to incomplete type
msc_test.c:208: error: dereferencing pointer to incomplete type
msc_test.c:224: error: dereferencing pointer to incomplete type
msc_test.c: In function `init_msr':
msc_test.c:254: error: `request_rec' undeclared (first use in this function)
msc_test.c:254: error: (Each undeclared identifier is reported only once
msc_test.c:254: error: for each function it appears in.)
msc_test.c:255: error: syntax error before ')' token
msc_test.c:300: error: invalid application of `sizeof' to incomplete type `modsecurity.h'
msc_test.c:300: error: invalid application of `sizeof' to incomplete type `modsecurity.h'
msc_test.c:301: error: dereferencing pointer to incomplete type
msc_test.c:302: error: dereferencing pointer to incomplete type
msc_test.c:303: error: dereferencing pointer to incomplete type
msc_test.c:304: error: dereferencing pointer to incomplete type
msc_test.c:305: error: dereferencing pointer to incomplete type
msc_test.c:306: error: dereferencing pointer to incomplete type
msc_test.c:307: error: dereferencing pointer to incomplete type
msc_test.c:308: error: dereferencing pointer to incomplete type
msc_test.c:309: error: dereferencing pointer to incomplete type
msc_test.c:310: error: dereferencing pointer to incomplete type
msc_test.c:311: error: dereferencing pointer to incomplete type
msc_test.c:312: error: dereferencing pointer to incomplete type
msc_test.c:313: error: dereferencing pointer to incomplete type
msc_test.c:314: error: dereferencing pointer to incomplete type
msc_test.c:315: error: dereferencing pointer to incomplete type
msc_test.c:316: error: dereferencing pointer to incomplete type
msc_test.c:317: error: dereferencing pointer to incomplete type
msc_test.c:318: error: dereferencing pointer to incomplete type
msc_test.c:319: error: dereferencing pointer to incomplete type
msc_test.c:320: error: dereferencing pointer to incomplete type
msc_test.c:321: error: dereferencing pointer to incomplete type
msc_test.c:322: error: dereferencing pointer to incomplete type
msc_test.c:323: error: dereferencing pointer to incomplete type
msc_test.c:324: error: dereferencing pointer to incomplete type
msc_test.c:325: error: dereferencing pointer to incomplete type
msc_test.c: At top level:
modsecurity.h:147: warning: array 'module_directives' assumed to have one element
make: *** [msc_test.lo] Error 1

All of the 'No such file or directory' files are located in /usr/include/httpd/

why I am getting this error?

View 3 Replies


ADVERTISEMENT

Install Suhosin :: How I Can Install Mod_security

Nov 14, 2008

problem with install suhosin and ...

how i can install Mod_security

View 7 Replies View Related

How To Install Mod_Security On LiteSpeed

Jul 6, 2009

i'm using DirectAdmin ,

when i was using Apache , i installed & Compiled Mod_Sec 2 , now i installed LiteSpeed & i want compile mod_sec with LiteSpeed ,

View 6 Replies View Related

Install Mod_security On CPANEL

Apr 17, 2009

i have install modsecurity by WHM > Manage Plugins > check Name: modsecurity and save .and so without error its complite .

and restart my apache.

but i cant finde it in phpinfo and my Plugins in whm

View 3 Replies View Related

Mod_security && Apache 2.x After Install

Nov 6, 2007

I have installed mod_security2 with apache2.x with success

but when I try to restart apache I have this wrong Msg:

PHP Code:

httpd restarthttpd: Syntax error on line 34 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/modules/mod_security2.so into server: /usr/local/apache/modules/mod_security2.so: undefined symbol: msc_alert 

PHP Code:

[root@secure modsecurity-apache_2.1.3]# ls -la /usr/local/apache/modules/mod_security2.so-rwxr-xr-x  1 root root 52541 Nov  6 16:26 /usr/local/apache/modules/mod_security2.so[root@secure modsecurity-apache_2.1.3]# 

View 5 Replies View Related

How To Install Mod_security For Ubuntu Gutsy

Jan 14, 2008

Cant seem to find anywhere that has a tutorial or instructions on how to install mod security for ubuntu gutsy, has anyone installed it lately and like to share their experience or tell how? Ive google to try find answer about 4 times now in last 2 weeks and still havent found anything.

View 1 Replies View Related

Everyone Should Install And Run Mod_Security On LAMP Server?

Jan 23, 2008

For a LAMP server user, is there a general consensus that everyone should pretty much install and run ModSecurity? Is there ever a good reason not too?

View 1 Replies View Related

How To Install Mod_security, Suhosin, Mod_Evasive On Server Plesk (apache2, Php5)

Jul 26, 2007

how to install mod_security, suhosin, Mod_Evasive on server plesk (apache2, php5)?
win I loacate apxs I have empty results

View 4 Replies View Related

Mod_security Rules & 500 Error

Nov 4, 2009

I am having the Modsec 2.5.9 I am using the defaults rules by the cpanel when i try to update the rules along with default rules given by the cpanel i am getting internal server error (500 Error)

The rules i tried to implement are from

Quote:

[url]

View 5 Replies View Related

Error Emails From Mod_Security

Nov 28, 2008

I got quite a lot of these e-mails from my mod_security

Quote:

[Thu Nov 27 23:36:44 2008] [error] [client 75.165.229.140] ModSecurity: Access denied with code 406 (phase 2). Pattern match "(ht|f)tps?:/" at ARGS:loc.

[file "/usr/local/apache/conf/modsec2/rules.conf"] [line "155"] [id "300018"] [rev "3"] [msg "Generic PHP code injection protection via ARGS"] [severity "CRITICAL"] [hostname "www.domain"] [uri "/ads/www/delivery/lg.php"] [unique_id "SS@DbEo-wEIAABlHa1YAAAAX"]

View 4 Replies View Related

Having 406 Error In Wordpress Blog : Mod_security Prb

May 6, 2009

I'm getting this 406 error in my blog. I read about this and learned that this error is related to Apache mod called "mod_security".

I tried to turn it off for my site using .htaccess file by

<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

But it didn't work. So how to get this sort this out ?

Asking Hosting provider to turn it off is out of question .Already asked but they don't want ( can't blame them )

View 9 Replies View Related

Mod_security Internal Server Error

Jan 2, 2008

I installed new apache (2.2.6) and mod_security 2. I wish to block some file globally by:

SecRule REQUEST_URI ".*(some_file).php?.*" 

but how to NOT BLOCL for some folder / account? I tried to add to .htaccess:

<Files some_file.php>SecFilterInheritance Off</Files> 

or

<Files some_file.php>SecRule Off</Files> 

or

<IfModule mod_security2.c>SecRule Off</IfModule> 

or

<IfModule mod_security2.c>    SecRuleEngine Off</IfModule> 

but always I have Internal Server Error

View 8 Replies View Related

Error On Install Mod_evasive

Mar 25, 2009

i want to install mod on my centos Cpanel server. so i try:

cd /usr/local/src
wget mod_evasive_1.10.1.tar.gz
tar -zxf mod_evasive_1.10.1.tar.gz
cd mod_evasive
/usr/sbin/apxs -cia mod_evasive20.c

but when i run /usr/sbin/apxs -cia mod_evasive20.c there is some error for me :

[root@ mod_evasive]#/usr/sbin/apxs -cia mod_evasive20.c
-bash: /usr/sbin/apxs: No such file or directory

View 8 Replies View Related

Error Install Ioncube

Apr 24, 2009

i use VPS:
ram 1GB,
centos 5.3 x86_64
whm/cpanel

i have problem install ioncube,

i install with rebuild apache to 2.2 and use php 5.2.9
after finish rebuild:

Option Value
Default PHP Version (.php files)
PHP 5 Handler None
PHP 4 Handler None
Suexec On

Php Version is cant select, and i check with root by ssh:

root@server [~]# php -v
The ionCube PHP Loader is disabled because of startup problems.
Segmentation fault
root@server [~]#

View 8 Replies View Related

Error In Install Chkrootkit-0.48

May 29, 2008

I have following error when try to install chkrootkit-0.48 on server:

[root@m5088 chkrootkit-0.48]# make sense
gcc -DHAVE_LASTLOG_H -o chklastlog chklastlog.c
make: gcc: Command not found
make: *** [chklastlog] Error 127

How can resolve this issue?

View 4 Replies View Related

Error Install Postgresql

Dec 21, 2007

The postgresql not start on my server. Use REDHAT Enterprise 4, I tried to install the command:

/scripts /installpostgres

But I returned the following error:

[root@s2 backups]# /scripts/installpostgres
This script will install Postgres 7.3.x or later
If you have an older version installed you wil need to
Dump your databases to a file and then restore them
after the install as 7.3.x is not backwards compatible.
If you do not have any databases, you can just run:
mv /var/lib/pgsql /var/lib/pgsql.old
/sbin/service postgresql stop
/sbin/service postgresql start
to force creating a 7.3.x style setup. Do not do this if
you have databases that you wish to keep!

Are you sure you wish to proceed? y

Fetching Obsoletes list for channel: rhel-i386-es-4...

Fetching rpm headers...

Name Version Rel
----------------------------------------------------------

The following packages you requested were not found:
rh-postgresql
rh-postgresql-devel
rh-postgresql-libs
rh-postgresql-server

The following packages you requested are already updated:
postgresql-libs
postgresql-server
postgresql
postgresql-devel
Stopping postgresql service: [FAILED]
postmaster: no process killed
postmaster: no process killed
Starting postgresql service: [FAILED]
You should now configure postgresql from WHM!
You should now configure postgresql from WHM!
You should now configure postgresql from WHM!
You should now configure postgresql from WHM!

View 3 Replies View Related

Error Guestbook Install

Sep 12, 2007

I have installed Lazarus Guestbook. Have already edited the configuration file However now when I run the install script on the page it is giving me an error "Could not connect to MySQL because: Access denied for user 'tof2005'@'localhost' (using password: NO)".

View 5 Replies View Related

Getting Error When Trying To Install Ssl For Client Area

Mar 28, 2009

Im trying to install an ssl purchased from godaddy for my client area using whm on my dedicated box

[url]

but keep getting an error:

"Sorry, you must have a dedicated ip to use this feature for the user: mydomain! If you are intending to install a shared certificate you must use the username "nobody" for security and bandwidth reporting reasons"

well its a dedicated box and i do have a dedicated ip of course

View 12 Replies View Related

Install KDE Using YUM :: Error: Missing Dependency

Jul 1, 2009

Have a CentOS 5.3 VPS. Trying to install KDE using Yum.

Get following error:

Error: Missing Dependency: cups-libs = 1:1.3.7-8.el5 is needed by package 1:cups-1.3.7-8.el5.x86_64 (base)

I tried using Yum to install both "cups-1.3.7-8.el5" entries in the search but they are already installed.

View 6 Replies View Related

How To Install PHP5 On CentOS 4? I Get An Error

Jun 23, 2007

with installing PHP5 on CentOS? I tried this:

Quote:

$ yum --enablerepo=centosplus --exclude=php-domxml install php*
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package php-pear-Cache.noarch 0:1.5.5-0.1.RC4.el4.centos set to be updated
---> Package php-odbc.x86_64 0:5.1.6-3.el4s1.7 set to be updated
---> Package php-pear-Net-Curl.noarch 0:1.2.3-2.el4.centos set to be updated
---> Package php-mhash.x86_64 0:5.1.6-1.el4.centos set to be updated
---> Package php-dbase.x86_64 0:5.1.6-1.el4.centos set to be updated
---> Package php-mysql.x86_64 0:5.1.6-3.el4s1.7 set to be updated
---> Package php-gd.x86_64 0:5.1.6-3.el4s1.7 set to be updated
---> Package php-pear-XML-Beautifier.noarch 0:1.1-1.el4.centos set to be updated
---> Package php-mcrypt.x86_64 0:5.1.6-1.el4.centos set to be updated
---> Package php-pear-HTTP.noarch 0:1.4.0-7.el4.centos set to be updated
---> Package php-xml.x86_64 0:5.1.6-3.el4s1.7 set to be updated
---> Package php-pear-XML-Serializer.noarch 0:0.18.0-2.el4.centos set to be updated
---> Package php-pecl-apc.x86_64 0:3.0.12-1.el4.centos set to be updated
---> Package php-pear-Validate-Finance-CreditCard.noarch 0:0.5.2-1.el4.centos set to be updated
---> Package php-pear-Date.noarch 0:1.4.6-1.el4.centos set to be updated
---> Package php-pear-XML-Parser.noarch 0:1.2.7-4.el4.centos set to be updated
---> Package php-soap.x86_64 0:5.1.6-3.el4s1.7 set to be updated
---> Package php-pear-Net-Socket.noarch 0:1.0.6-5.el4.centos set to be updated
---> Package php-pear-XML-Util.noarch 0:1.1.1-1.el4.centos set to be updated
---> Package php-pgsql.x86_64 0:5.1.6-3.el4s1.7 set to be updated
---> Package php-pear-MDB2.noarch 0:2.2.2-2.el4.centos set to be updated
---> Package php-eaccelerator.x86_64 0:5.1.6_0.9.5-1.el4.centos set to be updated
---> Package php-pear-PHP-Compat.noarch 0:1.5.0-1.el4.centos.1 set to be updated
---> Package php-pear-HTTP-Request.noarch 0:1.4.0-1.el4.centos set to be updated
---> Package php-pecl-mailparse.x86_64 0:2.1.1-4.el4.centos set to be updated
---> Package php-pear-XML-RSS.noarch 0:0.9.10-2.el4.centos set to be updated
---> Package php-dba.x86_64 0:5.1.6-3.el4s1.7 set to be updated
---> Package php-common.x86_64 0:5.1.6-3.el4s1.7 set to be updated
---> Package php-ncurses.x86_64 0:5.1.6-3.el4s1.7 set to be updated
---> Package php-pear-HTML-Table.noarch 0:1.7.5-1.el4.centos set to be updated
---> Package php.x86_64 0:5.1.6-3.el4s1.7 set to be updated
---> Package php-pear-DB.noarch 0:1.7.6-6.el4.centos set to be updated
---> Package php-pear-Mail-Mime.noarch 0:1.3.1-8.el4.centos set to be updated
---> Package php-pear-Auth-SASL.noarch 0:1.0.2-4.el4.centos set to be updated
---> Package php-pear-Mail.noarch 0:1.1.14-1.el4.centos set to be updated
---> Package php-pear-PHPUnit.noarch 0:1.3.2-1.el4.centos.1 set to be updated
---> Package php-pear-Net-URL.noarch 0:1.0.14-1.el4.centos set to be updated
---> Package php-pear-Console-Table.noarch 0:1.0.5-2.el4.centos.1 set to be updated
---> Package php-pear-Net-DIME.noarch 0:0.3-1.el4.centos set to be updated
---> Package php-pear-Pager.noarch 0:2.4.2-1.el4.centos set to be updated
---> Package php-pdo.x86_64 0:5.1.6-3.el4s1.7 set to be updated
---> Package php-pear-Log.noarch 0:1.9.9-1.el4.centos set to be updated
---> Package php-bcmath.x86_64 0:5.1.6-3.el4s1.7 set to be updated
---> Package php-pear-Benchmark.noarch 0:1.2.6-1.el4.centos set to be updated
---> Package php-snmp.x86_64 0:5.1.6-3.el4s1.7 set to be updated
---> Package php-pear-Net-SMTP.noarch 0:1.2.8-5.el4.centos set to be updated
---> Package php-pear.noarch 1:1.4.11-1.el4s1.1 set to be updated
---> Package php-xmlrpc.x86_64 0:5.1.6-3.el4s1.7 set to be updated
---> Package php-pear-DB-QueryTool.noarch 0:1.0.3-1.el4.centos set to be updated
---> Package php-pear-PHPUnit2.noarch 0:2.3.6-1.el4.centos set to be updated
---> Package php-devel.x86_64 0:5.1.6-3.el4s1.7 set to be updated
---> Package php-mbstring.x86_64 0:5.1.6-3.el4s1.7 set to be updated
---> Package php-pear-Payment-Process.noarch 0:0.6.5-1.el4.centos set to be updated
---> Package php-pear-Net-FTP.noarch 0:1.3.2-1.el4.centos set to be updated
---> Package php-pear.x86_64 0:4.3.9-3.22.5 set to be updated
---> Package php-cli.x86_64 0:5.1.6-3.el4s1.7 set to be updated
---> Package php-readline.x86_64 0:5.1.6-1.el4.centos set to be updated
---> Package php-pear-Console-Getargs.noarch 0:1.3.3-1.el4.centos set to be updated
---> Package php-imap.x86_64 0:5.1.6-3.el4s1.7 set to be updated
---> Package php-pecl-zip.x86_64 0:1.8.0-1.el4.centos set to be updated
---> Package php-pear-Validate.noarch 0:0.6.4-1.el4.centos set to be updated
---> Package php-pear-Date-Holidays.noarch 0:0.16.1-1.el4.centos set to be updated
---> Package php-pear-HTML-Common.noarch 0:1.2.3-2.el4.centos set to be updated
---> Package php-pear-PHP-CompatInfo.noarch 0:1.4.0-1.el4.centos set to be updated
---> Package php-ldap.x86_64 0:5.1.6-3.el4s1.7 set to be updated
---> Package php-pear-Image-GraphViz.noarch 0:1.2.1-1.el4.centos set to be updated
---> Package php-tidy.x86_64 0:5.1.6-1.el4.centos set to be updated
--> Running transaction check
--> Processing Conflict: php-pecl-apc conflicts php-eaccelerator
--> Processing Dependency: autoconf for package: php-devel
--> Processing Dependency: libexslt.so.0()(64bit) for package: php-xml
--> Processing Dependency: libmcrypt.so.4()(64bit) for package: php-mcrypt
--> Processing Dependency: php-pecl(Xdebug) for package: php-pear-PHPUnit2
--> Processing Dependency: graphviz for package: php-pear-Image-GraphViz
--> Processing Dependency: libmhash.so.2()(64bit) for package: php-mhash
--> Processing Dependency: net-snmp for package: php-snmp
--> Processing Dependency: libpq.so.4()(64bit) for package: php-pgsql
--> Processing Dependency: libltdl.so.3()(64bit) for package: php-mcrypt
--> Processing Dependency: libmysqlclient.so.15()(64bit) for package: php-mysql
--> Processing Dependency: php = 4.3.9-3.22.5 for package: php-pear
--> Processing Dependency: libmysqlclient.so.15(libmysqlclient_15)(64bit) for package: php-mysql
--> Processing Dependency: automake for package: php-devel
--> Processing Dependency: libnetsnmp.so.5()(64bit) for package: php-snmp
--> Processing Dependency: libtidy-0.99.so.0()(64bit) for package: php-tidy
--> Processing Dependency: libxslt.so.1()(64bit) for package: php-xml
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libtidy.x86_64 0:0.99.0-9.20051025.el4.centos.3 set to be updated
---> Package postgresql-libs.x86_64 0:8.1.9-1.el4s1.1 set to be updated
---> Package net-snmp-libs.x86_64 0:5.1.2-11.EL4.10 set to be updated
---> Package libxslt.x86_64 0:1.1.11-1 set to be updated
---> Package libtool-libs.x86_64 0:1.5.6-4.EL4.1.c4.4 set to be updated
---> Package autoconf.noarch 0:2.59-5 set to be updated
---> Package automake.noarch 0:1.9.2-3 set to be updated
---> Package mysql.x86_64 0:5.0.27-1.el4.centos set to be updated
---> Package net-snmp.x86_64 0:5.1.2-11.EL4.10 set to be updated
---> Package libmcrypt.x86_64 0:2.5.7-4.el4.centos set to be updated
---> Package mhash.x86_64 0:0.9.2-4 set to be updated
--> Running transaction check
--> Processing Conflict: php-pecl-apc conflicts php-eaccelerator
--> Processing Dependency: libgpg-error.so.0()(64bit) for package: libxslt
--> Processing Dependency: php-pecl(Xdebug) for package: php-pear-PHPUnit2
--> Processing Dependency: libgcrypt.so.11()(64bit) for package: libxslt
--> Processing Dependency: graphviz for package: php-pear-Image-GraphViz
--> Processing Dependency: libmysqlclient.so.14(libmysqlclient_14)(64bit) for package: mysql-server
--> Processing Dependency: mysql = 4.1.20-2.RHEL4.1 for package: mysql-server
--> Processing Dependency: libpq.so.3()(64bit) for package: dovecot
--> Processing Dependency: libmysqlclient.so.14()(64bit) for package: mysql-server
--> Processing Dependency: libmysqlclient_r.so.14()(64bit) for package: mysql-server
--> Processing Dependency: php = 4.3.9-3.22.5 for package: php-pear
--> Processing Dependency: mysql = 4.1.20-2.RHEL4.1 for package: mysql-devel
--> Processing Dependency: libmysqlclient.so.14()(64bit) for package: perl-DBD-MySQL
--> Processing Dependency: libmysqlclient_r.so.14(libmysqlclient_14)(64bit) for package: mysql-server
--> Processing Dependency: libmysqlclient.so.14(libmysqlclient_14)(64bit) for package: dovecot
--> Processing Dependency: libmysqlclient.so.14()(64bit) for package: dovecot
--> Processing Dependency: m4 for package: autoconf
--> Processing Dependency: libsensors.so.3()(64bit) for package: net-snmp
--> Processing Dependency: libgcrypt.so.11(GCRYPT_1.2)(64bit) for package: libxslt
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package mysqlclient14.x86_64 0:4.1.22-1.el4s1.1 set to be updated
---> Package postgresqlclient7.x86_64 0:7.4.14-1.el4s1.1.el4.centos set to be updated
---> Package mysql-server.x86_64 0:5.0.27-1.el4.centos set to be updated
---> Package m4.x86_64 0:1.4.1-16 set to be updated
---> Package lm_sensors.x86_64 0:2.8.7-2.40.3 set to be updated
---> Package libgcrypt.x86_64 0:1.2.0-3 set to be updated
---> Package mysql-devel.x86_64 0:5.0.27-1.el4.centos set to be updated
---> Package perl-DBD-MySQL.x86_64 0:3.0008-1.el4.centos set to be updated
---> Package libgpg-error.x86_64 0:1.0-1 set to be updated
--> Running transaction check
--> Processing Conflict: php-pecl-apc conflicts php-eaccelerator
--> Processing Dependency: php-pecl(Xdebug) for package: php-pear-PHPUnit2
--> Processing Dependency: graphviz for package: php-pear-Image-GraphViz
--> Processing Dependency: perl(:MODULE_COMPAT_5.8.8) for package: perl-DBD-MySQL
--> Processing Dependency: php = 4.3.9-3.22.5 for package: php-pear
--> Processing Dependency: kernel-utils for package: lm_sensors
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package kernel-utils.x86_64 1:2.4-13.1.99 set to be updated
---> Package perl.x86_64 4:5.8.8-4.el4s1 set to be updated
--> Running transaction check
--> Processing Conflict: php-pecl-apc conflicts php-eaccelerator
--> Processing Dependency: graphviz for package: php-pear-Image-GraphViz
--> Processing Dependency: php = 4.3.9-3.22.5 for package: php-pear
--> Processing Dependency: php-pecl(Xdebug) for package: php-pear-PHPUnit2
--> Finished Dependency Resolution
Error: php-pecl-apc conflicts with php-eaccelerator
Error: Missing Dependency: php-pecl(Xdebug) is needed by package php-pear-PHPUnit2
Error: Missing Dependency: graphviz is needed by package php-pear-Image-GraphViz
Error: Missing Dependency: php = 4.3.9-3.22.5 is needed by package php-pear

Anyone know how to resolve these dependencies?

View 4 Replies View Related

Install CentOS 5 :: Error: Failed Dependencies

Apr 12, 2009

I've bought an VPS recently but now I have a problem. It didn't come with yum installed so I need to install it on my own...

Now, I have a problem.

When I try to do:

Code:
# rpm -Uvh yum-3.2.19-18.el5.centos.noarch.rpm
This comes out:

Code:
warning: yum-3.2.19-18.el5.centos.noarch.rpm: Header V3 DSA signature: N
OKEY, key ID e8562897
error: Failed dependencies:
yum-fastestmirror is needed by yum-3.2.19-18.el5.centos.noarch

So I suppose I need to install the yum-fastestmirror first.
But when I try:

Code:
# rpm -Uvh yum-fastestmirror-1.1.16-13.el5.centos.noarch.
rpm
This comes out:

Code:

warning: yum-fastestmirror-1.1.16-13.el5.centos.noarch.rpm: Header V3 DS
A signature: NOKEY, key ID e8562897
error: Failed dependencies:
yum >= 3.0 is needed by yum-fastestmirror-1.1.16-13.el5.centos.n

View 11 Replies View Related

Plesk 12.x / Linux :: Wordpress Install Error?

Mar 10, 2015

HTTP Error (404)

[URL] ....

This is the error I get when trying to install wordpress

View 10 Replies View Related

Plesk 11.x / Linux :: Error When Install Horde With 11.5.30?

May 11, 2014

I'm facing a problems with my plesk 11.5.30 (latest update with CentOS 6.x).

One subscription can't switch between horde and round-cube. When they change to round-cube, it's still running Horde. To solve this problems, I tried remove Horde (everything's fine, successful) and install it again (error).

View 9 Replies View Related

Plesk 12.x / Linux :: FTP Login Error 530 After Install

Nov 8, 2014

I just finished installing Plesk Panel 12. I seems like that everything is working as it should, except for FTP. I am not able to login with any FTP accounts.

View 13 Replies View Related

Plesk Automation :: Install Mediawiki / Applications Tab Error

Apr 28, 2014

I have to install mediawiki application on a client website, but during installations process occur this problem, PPA version is 11.1 :

View 2 Replies View Related

Error: Install: %pre Scriptlet Failed (2), Skipping MYSQL-PACKAGE-NAME

Mar 31, 2008

I've been having trouble installing MySQL 5, strangely, on this VPS.

Upon every install, it is bound to give me the same error.

Quote:

root@host [~/src]# rpm -i --nodeps MySQL-server-community-5.0.51a-0.rhel5.i386.rpm
error: install: %pre scriptlet failed (2), skipping MySQL-server-community-5.0.51a-0.rhel5

Quote:

root@zendfree [~/src]# rpm -i --nodeps MySQL-server-5.0.51a-0.glibc23.i386.rpm
error: install: %pre scriptlet failed (2), skipping MySQL-server-5.0.51a-0.glibc23

I've tried out various RPMs - all of which gives :

error: install: %pre scriptlet failed (2), skipping MYSQL-PACKAGE-NAME.

View 14 Replies View Related

Plesk 11.x / Linux :: Error On Upgrade - Yum Utility Failed To Install Required Packages

Jun 23, 2014

I am trying to upgrade my Plesk 11.5.30 install to 12.x but I keep getting an error:

Exception: Failed to solve dependencies:
php-devel-5.4.29-35.el6.art.x86_64 requires php-cli(x86-64) = 5.4.29-35.el6.art
Error: The Yum utility failed to install the required packages.
Attention! Your software might be inoperable.
Please, contact product technical support.

I have run the boostrapper repair but the error remains.

View 2 Replies View Related

Plesk 12.x / Linux :: Possible To Install To Debian Jessie With Auto-install Script?

Jul 19, 2015

Is it possible to install Plesk 12 to Debian Jessie with the autoinstall script?

View 7 Replies View Related

Mod_Security 2.5, Or 2.0?

Apr 21, 2008

I have been using mod_security 1.9.x since it first release on apache 1.3 and apache 2.0.x, rules are great and they work perfect with no issues at all with any php-mysql website. Do you recommend using mod_security 2.0 or 2.5 ? (I do know that 2.5 does not work with apache 1.3).

View 2 Replies View Related







Copyrights 2005-15 www.BigResource.com, All rights reserved