802.3ad (bonding/link Aggregation) On Cisco 2960 W/linux

Aug 14, 2009

I thought with 802.3ad I could aggregate the links and thus turn a 3x100 megabit pipes to one 300 meg pipe. The problem is when using the default options (and layer2 xmit mode) I only get the bandwidth of a single connection and I see no other traffic on the other two. Here is output from /proc/net/bonding/bond0:

Code:
Ethernet Channel Bonding Driver: v3.3.0 (June 10, 2008)

Bonding Mode: IEEE 802.3ad Dynamic link aggregation
Transmit Hash Policy: layer2 (0)

MII Status: up
MII Polling Interval (ms): 100
Up Delay (ms): 0
Down Delay (ms): 0

802.3ad info
LACP rate: slow
Active Aggregator Info:
Aggregator ID: 2
Number of ports: 3
Actor Key: 9
Partner Key: 3
Partner Mac Address: 00:1e:f6:xx:xx:xx

Slave Interface: eth0
MII Status: up
Link Failure Count: 0
Permanent HW addr: 00:1e:8c:xx:xx:xx
Aggregator ID: 1

Slave Interface: eth2
MII Status: up
Link Failure Count: 0
Permanent HW addr: 00:04:23:xx:xx:xx
Aggregator ID: 1

Slave Interface: eth3
MII Status: up
Link Failure Count: 0
Permanent HW addr: 00:04:23:xx:xx:xx
Aggregator ID: 1
Basically it works in that I get a connection but its no different from being on a regular 100/100 connection. Downloading files my machine from completely different networks always only goes out one connection. I don't even see any received/sent packets from the other two interfaces.

When I tell it to use layer3+4 via the xmit_hash_policy paramter when loading the module IE:

modprobe bonding mode=4 xmit_hash_policy=layer3+4 miimon=100

It seems to work as expected except it looks like all incomming traffic comes in on the same interface and its not much different from a normal load balancing (except from a single IP address). I will stick to this method if I have no choice as I don't really care about the download all that much and it seems to do a good job.

Here is /proc/net/bonding/bond0 from that config:

Code:
Ethernet Channel Bonding Driver: v3.3.0 (June 10, 2008)

Bonding Mode: IEEE 802.3ad Dynamic link aggregation
Transmit Hash Policy: layer3+4 (1)
MII Status: up
MII Polling Interval (ms): 100
Up Delay (ms): 0
Down Delay (ms): 0

802.3ad info
LACP rate: slow
Active Aggregator Info:
Aggregator ID: 2
Number of ports: 3
Actor Key: 9
Partner Key: 3
Partner Mac Address: 00:1e:f6:xx:xx:xx

Slave Interface: eth0
MII Status: up
Link Failure Count: 0
Permanent HW addr: 00:1e:8c:xx:xx:xx
Aggregator ID: 2

Slave Interface: eth2
MII Status: up
Link Failure Count: 0
Permanent HW addr: 00:04:23:xx:xx:xx
Aggregator ID: 2

Slave Interface: eth3
MII Status: up
Link Failure Count: 0
Permanent HW addr: 00:04:23:xx:xx:xx
Aggregator ID: 2

My understanding is that with layer2 it should just be one big fat pipe. IE: packets are fragmented and thus even a single connection should be able to sustain 300 megabits (if the other end could provide it). It seems like it just doesn't use my other interfaces at all when doing this.

Here is my config on the cisco 2960:

Code:
interface Port-channel3
switchport access vlan 100
switchport trunk allowed vlan 100
switchport mode access
switchport nonegotiate
spanning-tree portfast
!
interface FastEthernet0/10
switchport access vlan 100
switchport trunk allowed vlan 100
switchport mode access
switchport nonegotiate
channel-protocol lacp
channel-group 3 mode active
spanning-tree portfast
!
interface FastEthernet0/38
switchport access vlan 100
switchport trunk allowed vlan 100
switchport mode access
switchport nonegotiate
channel-protocol lacp
channel-group 3 mode active
spanning-tree portfast
!
interface FastEthernet0/40
switchport access vlan 100
switchport trunk allowed vlan 100
switchport mode access
switchport nonegotiate
channel-protocol lacp
channel-group 3 mode active
spanning-tree portfast

View 5 Replies


ADVERTISEMENT

Colo Link Aggregation / 802.3ad Alternatives

Apr 28, 2008

I run a small streaming/cdn service and I'm looking at how best to utilize my bandwidth. Here's the scoop:

I have a 1/4 rack and 2 gbit drops from my provider. Currently I am running a single server connected to 1 gbit port - nothing fancy. Business is good so I am about to add another server. As this location is already the backup/failover for my primary colo (different location/provider), I am interested in playing with aggregation options.

I have used 802.3ad in the past, so that was my first choice. I asked my provider if they can trunk my ports on their switch - unfortunately they refused (they only allow it above a certain commit).

So...do I have any other options for aggregation? It's pure mb/sec throughput that I am looking for, rather than failover. I have the rackspace/power/etc to colo my own switch or router, I'm just curious if there is an effective alternative.

View 6 Replies View Related

Cisco 2950 Vs. 2960

May 12, 2008

Is there much advantage to going with the 2960 series switches vs. the 2950 series? Basically I'm looking at 24 port and 48 port switches (10/100) with GBIT (copper) uplinks.

View 2 Replies View Related

New Cisco 2960 Switch Keeps Going Offline Every 12 Hours.

Dec 9, 2007

new Cisco 2960 switch keeps going offline every 12 hours.

I will power cycle it, then about 12 hours later it goes off again. This is a brand new switch.

View 9 Replies View Related

Apache :: How To Redirect Old Blog Link To New Link

Mar 30, 2013

I moved my wordpress blog from blog.domain.info to domain.net i own both the tld domains. google search already had the posts from old url indexed. if someone clicks in it it shows 404 error. how do i redirect the traffic from old url to new url via htaccess. I dont want duplicate post on google. how to make the transition? i am confused with many online articles about htaccess redirect. 

View 2 Replies View Related

NIC Bonding And Switches

Jul 2, 2008

I just stumbled across mention of bonding two NICs to serve as one. (E.g., 100Mbps NIC + 100Mbps NIC = 'virtual' 200 Mbps NIC, as far as everything on the network is concerned.)

I'd been familiar with the concept for quite some time, but I guess I never really thought it through until just now...

How does this work with switches? It seems to me that the answer should be a flat, "It doesn't." But it seems that it does work. How does the switch merrily map an IP to two different ports? Do the two NICs maintain their MACs? (Wouldn't two MACs to one IP cause even more problems?)

View 1 Replies View Related

MLPPP (ADSL Bonding)

Oct 25, 2009

I am thinking of bonding several ADSL connections at my house in order to get a faster upload speed to my servers.

Does anyone know of any good routers out there that could do this job (Cisco or HP would be preferred, but any brand is okay)?

View 2 Replies View Related

Plesk 11.x / Linux :: Can't Access PhpMyAdmin From Direct Link

Jan 3, 2015

Plesk: 12.0.18
phpMyAdmin: 4.2.5

When I try to access phpMyAdmin directly from the link: [URL] ....

I get the following error:

Welcome to phpMyAdmin

You probably did not create a configuration file. You might want to use the setup script to create one.

Error

MySQL said: Documentation
Cannot connect: invalid settings.
Retry to connectClick to expand...

View 3 Replies View Related

Plesk 11.x / Linux :: Remove OsTicket And Link In Panel

Jun 1, 2014

I know now how to install the integrated Help Desk funktion. But how do I remove the Link "Install Help Desk" when I remove the Applications osTicket?

View 1 Replies View Related

Are The 100Mbps Of LeaseWeb True ? Without Aggregation Ratio (without Share)

Nov 26, 2008

We are seeking for a new dedicated servers company.

Actually we have 2 windows servers(1Database

View 10 Replies View Related

Plesk 12.x / Linux :: Webmail Shows Only Text After Changing Link

Sep 18, 2014

I've upgraded from WS2008R2 & IIS to CentOS and Plesk 12.Now, I wanted to change the webmail link for all domains to mail.domain instead of webmail.domain. I've followd 2 guides to do that: URLs....Everything went smooth, but now Horde and Roundcube look like this (even when I restarted the whole server):

View 12 Replies View Related

Plesk 12.x / Linux :: Facebook Link In Control Panel Can Be Removed?

Apr 22, 2015

I purchased a Host license.Major customers in China. There is a facebook link in the panel.But China does not allow access facebook. This leads to a very slow access speed! Can I remove this link? If so, how to remove?

View 1 Replies View Related

Invalid Cross-device Link - Additional Hard Drives Linux

Mar 25, 2008

OP: Linux Centos

I just got an additional 500GB hard drive added and mounted it to /home2

There are files that are in /home1 (orginal HD) that will need to be constantly moved over to /home2 via a ftp

But i keep getting this error

550 Rename/move failure: Invalid cross-device link

Does anyone have any ideas? I tried changing permissions but no luck also tried mounting the 2nd hard drive within a directory in /home1. Still gives the error.

View 5 Replies View Related

Plesk 12.x / Linux :: Link In Home Page Of Server Administration Panel

Oct 21, 2014

I tried to install "help desk" from the Plesk link in the Home Page of the Server Administration Panel,but in this installation appear a message that block the installation process..Warning: Possible phishing attempt detected: The link you used attempted to redirect you to another site.

View 9 Replies View Related

Linux Cisco VPN Client - Two Concurrent Connections Possible?

Jun 21, 2008

Server: Dell 2950
onboard NIC only
CentOS 4.6

Is it possible to run two concurrent VPN connections using the Linux Cisco VPN client? We need to have one server be able to communicate over two different vendors gateways.

Do we need to possibly add an additional NIC to the server first?

When we try to connect to another profile we get the error:

Initializing the VPN connection.

Secure VPN Connection terminated locally by the Client

Reason: A connection already exists.

View 0 Replies View Related

Cisco 2950 - How To Enable "Cisco Network Assistant"

Dec 16, 2007

My host has helped me to install a switch. However, I don't know how to configure using the command line. Could anyone help me?

I need to be able to connect to my Cisco switch using Cisco Network Assistant. If you know the command sequence,

View 5 Replies View Related

Link IIS And DNS

Jan 9, 2008

Currently I have DNS as well as IIS configured on the same server. I am using host headers to seperate the sites on IIS. My question is how do I link my DNS to the website residing on IIS? My DNS server set (I can ping it from the internet) and I think I have IIS configured right, but I must be missing something?

View 1 Replies View Related

Link

Sep 22, 2007

On a webpage, I have two links:

[url]

and

[url]

The first one goes 404, and if your refresh the page you get the page.

The second goes directly to the page.

There is one other file in the /xyz directory and it is not named index.* and there is a temp directory.

I can type the url in a browser either way and it gets to you directly to the page. It seems only when it is a link that it is a problem.

View 4 Replies View Related

Link Redirect

Jan 30, 2008

I have a .swf file that I directly linked to digg. How can I redirect that specific file to a different page/server to relieve some of the pressure from all those users?

View 0 Replies View Related

*.mp3 Link File Hosting

Oct 27, 2009

any reliable audio hosting service that can offer an *.mp3 - ending link to a file, not the "server.com/folder/4j8uz22ewssw" thing, please? In other words I'm looking for a hosting service with a direct link to an mp3 (just to clear things up, its not copyrighted since I'm the owner of it).

View 14 Replies View Related

Permission To Link To Someone's Page

Jun 5, 2008

I was wondering: say I have a website where users discuss different articles and when a user wants to discuss a specific article, he/she will be able to link to that article and then say what they have to say.

Certainly, copying and pasting would violate the site's copyright but simply including a little link sounds like a legal alternative. Is it really? Or, technically that would still require me as the webmaster, or the user who posted it to request permission just for linking?

I know nobody would care because it only gives more traffic to the site but legally, would permission be needed?

View 5 Replies View Related

Link Files Instead Of Copying

Apr 5, 2008

to execute the following command into a Solaris 5.11 system.

cp -al ......

The problem is that either -a or -l works on Solaris.
Man pages are not installed and all I can get is:

Usage: cp [-f] [-i] [-p] [-@] f1 f2
cp [-f] [-i] [-p] [-@] f1 ... fn d1
cp -r|-R [-H|-L|-P] [-f] [-i] [-p] [-@] d1 ... dn-1 dn

What I want to achieve is link files instead of copying and also keep permissions on files.

View 1 Replies View Related

WTB: Hosting For My TV Link Sites

Jul 1, 2008

I have 2 TV link sites similar to tv-links.cc etc. Does anyone know where I can host such sites?

I know there are some legal issues with those sites (in certain countries) so I'm not sure who can/will host them.

I'm currently at FDC,

View 4 Replies View Related

Link A New Server To A Subdomain

Nov 4, 2008

I have a dedicated server hosted at domain.com. I want to get a new server and link it to something.domain.com

View 3 Replies View Related

Link Exchange Script

Jul 7, 2007

If you know about What script to use for 1:1 traffic exchange for a entertainment websites, please let me know as I am looking for some php scripts that does that automatically for a entertainment website

View 2 Replies View Related

How To Link Domain With Hosting

Jul 30, 2007

I have bought a domain name and hosting space from different sources. I,myself want to link the both.

View 5 Replies View Related

Awstats Direct Link

Sep 3, 2007

I am currently coding a backend to my website where clients can login and view their webmail, stats, etc.

What I am after is a script that will link my clients directly through to awstats, without going through cpanel or having to re-enter their username/password through the htaccess popup.

Does anybody know if I can pass the un/pwd combo through in the url string to popup the stats in the correct manner?

View 10 Replies View Related

Statically Link Php With Apache 2.0+

Jun 19, 2007

I was reading on the internet that it was not possible to link php and apache 2 statically.

If this is true then is my only option to install apache 1.3 and link it that way?

Are there any solution anyone know to get around this?

I know DSO is better but the problem is.. some software requires them to be statically linked so its something I have to solve.

View 2 Replies View Related

[lighttpd] Link Userdir To A Domain

Feb 3, 2008

I have installed lighttpd and set userdir to "public_html". In Apache, we can use WHM to link a userdir to a domain, e.g.:
"URL/~example/" => "example.org"

How do I do this for lighttpd?

View 2 Replies View Related

Canonical Phpinfo() Link Thread

May 27, 2008

I find that lots of hosts don't put the link to a phpinfo() script on their websites, even though that would save everyone a lot of unnecessary questions.

So I figure we should have a thread where people can add links to phpinfo scripts on their own hosts, or hosts where they happen to have the URL of a phpinfo script.

For those of you who own your own web hosting services, here's a chance to show off all your installed goodness, and all it takes is placing a simple link here (and put one in your FAQ section on your web site too, for the love of God)..

Since the forum doesn't allow editing your own posts (I still think that is nuts), please include all previous links in your post, so visitors will only need to read the LAST post to find all the updated links in one place.

View 5 Replies View Related

Symbolic Link Or .htaccess Redirection

Mar 16, 2007

cPanel interface and want to create friendly link to access phpmyadmin. So, here is my questions:

1- Is there a way directly in cPanel to do it?

2- What is the better way to do this: Symbolic link or simple redirection?

View 1 Replies View Related







Copyrights 2005-15 www.BigResource.com, All rights reserved